Unable to use Medeo

Incident Report for QHR Technologies Status Page

Resolved

We have resolved this issue.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 24, 2026 - 11:39 EDT

Monitoring

We have resolved this issue.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted May 24, 2026 - 11:38 EDT

Investigating

Our team is currently investigating an issue where providers are unable to use Medeo and receiving Gateway 502 & 504 Error
Posted May 24, 2026 - 10:50 EDT
This incident affected: Medeo.