Ontario MD Lab Outage

Incident Report for QHR Technologies Status Page

Resolved

Ontario MD has resolved this outage.
Posted Oct 07, 2025 - 19:35 EDT

Update

Please be advised we are aware of a outage with Ontario MD - this would be affecting any Ontario clinics labs. Please reach out to Ontario MD for further information support@ontariomd.com 1-866-250-1554
Posted Oct 07, 2025 - 15:13 EDT

Update

Ontario MD is still experiencing an outage that will impact Accuro clients in Ontario. Please reach out to Ontario MD for further information support@ontariomd.com 1-866-250-1554
Posted Oct 07, 2025 - 13:57 EDT

Identified

Please be advised we are aware of a outage with Ontario MD - this would be affecting any Ontario clinics labs. Please reach out to Ontario MD for further information support@ontariomd.com 1-866-250-1554
Posted Oct 07, 2025 - 12:00 EDT
This incident affected: Vendor Outages (Non-QHR).