Unite- Atlantic, Saskatchewan, Manitoba sites- Degraded Performance

Incident Report for QHR Technologies Status Page

Update

Unite is continuing to investigate this issue.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 26, 2025 - 16:30 EST

Update

Unite is continuing to investigate this issue.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 26, 2025 - 07:18 EST

Update

Unite is continuing to investigate this issue.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 20:00 EST

Update

Unite is continuing to investigate this issue.

Please see Unite Status page for further updates-https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 19:23 EST

Investigating

Unite is currently experiencing an issue affecting the connectivity of their fax systems. They are aware of the problem and are working to put a solution in place. You can monitor for updates at https://unite.ca/networkstatus/
Posted Nov 25, 2025 - 15:43 EST
This incident affects: Vendor Outages (Non-QHR).