Printers may not be visible in new UI Accuro

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted May 14, 2025 - 11:13 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 11:13 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 20:00 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 14:15 EDT

Update

We are currently investigating an issue that some Tricerat Print Server clinics may not be able to see printers in the new UI - you can revert back to legacy at this time.
Posted May 13, 2025 - 12:36 EDT

Investigating

We are currently investigating this issue - please use legacy Accuro at this time.
Posted May 13, 2025 - 12:05 EDT
This incident affected: Accuro.