Unable to launch Accuro via Accuro.Cloud

Incident Report for QHR Technologies Status Page

Resolved

We recently resolved an issue that was impacting Accuro.Cloud services. All functionality has been fully restored. Need to report an issue? Please contact us at 1.866.729.8889 or support@qhrtech.com.
Posted Jan 27, 2022 - 10:27 EST

Monitoring

A fix has been implemented and we are currently monitoring the issue to confirm full recovery of Accuro Cloud services. Accuro Cloud clients should be able to log in using accuro.cloud at this time.
Posted Jan 27, 2022 - 09:52 EST

Update

We are continuing to investigate this issue. The next update will be at 10am EST.
Posted Jan 27, 2022 - 09:15 EST

Investigating

We are investigating reports of an issue that is preventing access to Accuro Cloud services. Thank you for your patience as we look into this. Please keep trying to log in as your connection may be restored soon and continue to check the status page for the latest updates.
Posted Jan 27, 2022 - 08:43 EST
This incident affected: Accuro.