Some users may be unable to print

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jul 03, 2025 - 08:59 EDT

Monitoring

We have issued a fix, please restart your accuro and log back in.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Jul 03, 2025 - 08:50 EDT

Identified

The issue has been identified and fix is being issued - users will need to log out and log back in,
Posted Jul 03, 2025 - 08:43 EDT

Update

We are currently investigating a issue that some users are unable to print.
Posted Jul 03, 2025 - 08:25 EDT

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 08:17 EDT
This incident affected: Accuro.