Some users may experience errors launching Accuro
Incident Report for QHR Technologies Status Page
Resolved
This incident has been resolved.
Need to report an issue? Please contact us at 1.866.729.8889
Posted Jul 21, 2024 - 15:03 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 21, 2024 - 13:37 EDT
Identified
This issue has been identified and a fix is being implemented.
Posted Jul 21, 2024 - 11:06 EDT
This incident affected: Accuro.