Unable to Launch Web Accuro

Incident Report for QHR Technologies Status Page

Resolved

We have resolved the Web Accuro issue.
Posted Jan 31, 2025 - 13:35 EST

Investigating

We have identified an issue that is requiring a reboot of some servers. This will take approximately 90 minutes to complete and may affect your ability to login to Accuro.
Posted Jan 31, 2025 - 10:50 EST
This incident affected: Accuro.