Error = Product: ScrewDrivers End point popping up - please click OK

Incident Report for QHR Technologies Status Page

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 07:17 EST

Investigating

Please be aware users may see a error pop up stating " Product: Screw Drivers Endpoint"
Please click past it and resume as normal - if you are having issues printing please call in for normal troubleshooting.
Posted Nov 26, 2025 - 06:46 EST
This incident affected: Accuro.