We have resolved this issue. Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Nov 17, 2024 - 11:03 EST
Identified
We have identified the issue causing errors for users attempting to launch Accuro or access Documents and are working on implementing a fix. Thank you for your patience.
Posted Nov 17, 2024 - 10:35 EST
Update
We are continuing to investigate the issue affecting some users trying to launch Accuro and the issue affecting other users from accessing Documents. Thank you for your patience.
Posted Nov 17, 2024 - 10:14 EST
Update
We are continuing to investigate the issue affecting users trying to launch Accuro. We are also investigating reports of users that are able to launch that cannot access Documents.
Posted Nov 17, 2024 - 09:42 EST
Update
We are continuing to investigate this issue. Thank you for your patience.
Posted Nov 17, 2024 - 09:10 EST
Investigating
We are investigating an issue that is affecting users trying to launch Accuro.