Accuro Performance - Slowness

Incident Report for QHR Technologies Status Page

Resolved

Thank you for your patience. We have resolved this issue.

Need to report an issue? Please contact our Client Services line at 1-866-729-8889.
Posted Nov 13, 2025 - 14:30 EST

Update

We are continuing to investigate this issue.
Posted Nov 13, 2025 - 13:30 EST

Investigating

We are currently investigating an issue where some users may be experiencing issues with slowness or performance while using Accuro.
Posted Nov 13, 2025 - 11:30 EST
This incident affected: Accuro.