Multiple Services Impacted (Faxes Queued, Web Accuro Errors)
Incident Report for QHR Technologies Status Page
Resolved
We recently resolved an issue that was impacting our services. All functionality has been fully restored. Need to report an issue? Please contact us at 1.866.729.8889or support@qhrtech.com.
Posted Sep 15, 2021 - 17:52 EDT
Update
This issue is still being investigated. The next update will be in 1 hour.
Posted Sep 15, 2021 - 16:36 EDT
Update
Unfortunately, we have no new updates at this time. This issue is still being investigated. Thank you for your continued patience. The next update will be in 1 hour.
Posted Sep 15, 2021 - 15:34 EDT
Update
This issue is still being investigated. The next update will be in 1 hour.
Posted Sep 15, 2021 - 14:42 EDT
Update
This issue is still being investigated. The next update will be in 1 hour.
Posted Sep 15, 2021 - 13:38 EDT
Update
Thank you for your continued patience. This issue is still being investigated. The next update will be in 30 minutes.
Posted Sep 15, 2021 - 13:07 EDT
Update
We are continuing to investigate this issue. The next update will be in 30 minutes. Thank you for your patience.
Posted Sep 15, 2021 - 12:39 EDT
Investigating
We are investigating reports of an issue that is preventing access to our services. Thank you for your patience as we look into this. Please continue to check the status page for the latest updates.
Posted Sep 15, 2021 - 10:30 EDT
This incident affected: Accuro.