Unable to Access Accuro
Incident Report for QHR Technologies Status Page
Resolved
We recently resolved an issue that was impacting our services. All functionality has been fully restored. We are continuing to monitor if there are any changes. Need to report an issue? Please contact us at 1.866.729.8889or support@qhrtech.com.
Posted Jun 27, 2022 - 20:28 EDT
Update
We are continuing to investigate this issue.
Posted Jun 27, 2022 - 20:27 EDT
Update
We are continuing to investigate this issue.
Posted Jun 27, 2022 - 20:22 EDT
Investigating
Some clients are currently unable to access Accuro via Citrix or Cloud at this time, we are currently investigating.
Posted Jun 27, 2022 - 19:57 EDT
This incident affected: Accuro, Medeo, Citrix, and FreedomRx.