Unable to Launch Accuro (ASP & Cloud) and Impact to Medeo Logins
Incident Report for QHR Technologies Status Page
Resolved
We recently resolved an issue that was impacting our services. All functionality has been fully restored. Need to report an issue? Please contact us at 1.866.729.8889 or support@qhrtech.com.
Posted Jun 28, 2022 - 14:55 EDT
Update
We are continuing to investigate this issue.
Posted Jun 28, 2022 - 14:20 EDT
Investigating
We are investigating reports of an issue that is preventing access to Accuro Cloud and ASP services. Thank you for your patience as we look into this. Please continue to check the status page for the latest updates.
Posted Jun 28, 2022 - 14:04 EDT
This incident affected: Accuro, Medeo, and Citrix.